Leica M Firmware UPDATE is HERE! Version 2.0.0.11

Leica M Firmware UPDATE is HERE! Version 2.0.0.11

FINALLY! Leica has released new firmware for the M 240 that they say improves the white balance of the camera. I have just downloaded it and will be testing it today and report back with my findings in about 30-45 minutes. But for now, go get it if you own a Leica M!

YOU can download the firmware HERE

SAMSUNG CSC

M (Type 240) Firmware Version 2.0.0.11

Improvements in firmware version 2.0.0.11 versus version 1.1.0.2

Improved performance of the white balance

The accuracy of the white balance presets and the auto white balance function is higher with version 2.0.0.11. This results in better skin tones and better general colour rendering.

Improved Video quality

The visibility of compression artifacts is reduced due to lower video compression.

Lens calibration

For coded Leica lenses, the image homogeneity (colour shift) has been improved.

General fixes

_Improved stability using Live View, both with and without EVF-2

_Issue with display settings in combination with “Sharpness high” – fixed _Issue with exposures after switching the camera on – fixed

_The “Auto Power Off” function showed unexpected behavior – fixed

_The recording dates for video files have been incorrect occasionally – fixed _Issue with Copyright and Artist Information in EXIF Data – fixed _Improvement of general system stability

_Several minor bug fixes

Related Post

18 Comments

  1. Ney Tavora says:
    I own a Leica M type 240
    MyElectronic Viewfinder Leica EVF 2 1003835 which was bought in Amazon, dated 04/06/2012, suddenly stopped working.
    I decided to buy a new EVF because I thought the problem was related to the EVF, not to the camera!
    I bought this week a new Leica EVF 2 1017103 also in Amazon which is dated 04/19/2013. But it also did not work in my camera!
    Nothing appears in the EVF when using either one of them in the camera Live View mode, of course.
    I just update my Leica M firmware to the latest FW_M240_2_0_0_0_12.FW dated 03/31/2014.
    Leica claims:”General Bugfixes _Improved stability using Live View with and without EVF-2″
    But the new firmware did not help at all. The problem persists.
    I am still expecting return from Leica support.
    I am hoping not to have to send my camera to be serviced.
    Any help from you, Steve, or from any of our friends?

    • Sounds like it needs service. 1st I have heard of this issue from anyone, but it sucks. No way to get it to work without sending it in and having it fixed.

  2. Is the firmware update done by copying to SD card and will the camera automatically update this when the SD card is inserted?

  3. I have downloaded the firmware file onto my iMac desktop, but every time I try to drag it to my formatted SD card, it develops a ‘No Entry’ sign and refuses to be put on the card.
    Any ideas?
    I have tried re-downloading the firmware, ejecting and remounting the SD card, etc, but no change to the behaviour.

  4. Great news, as I am still waiting on delivery of my silver/black Leica M (ordered March 2013). This should address some of the current issues. By the way Steve, Gariz case?

  5. Nice to get an update but I’m bummed there’s still no Auto ISO for Shutter Priority like I had on the M9.
    That said, I love this camera.

Comments are closed.